Index statistics unavailable
Incident Report for pganalyze
Resolved
The restore of historic index statistics data has been completed, and the unused index check will run again as scheduled.
Posted Dec 19, 2023 - 17:37 UTC
Update
We are continuing to restore affected historic index statistics. We anticipate full recovery in approximately 9 hours time.

We will provide the next update around 8am Pacific / 4pm UTC.
Posted Dec 19, 2023 - 08:13 UTC
Update
We are continuing to restore affected historic index statistics. We anticipate full recovery in approximately 12 hours time.

We will provide the next update around 12am Pacific / 8am UTC.
Posted Dec 19, 2023 - 04:41 UTC
Update
We are continuing to work on restoration of historic index statistics data. Current index statistics information shows up successfully now (e.g. for the current index size), but index-related graphs are missing historic information. The unused index check (in Index Advisor) continues to be unavailable, and you may also see intermittent errors accessing other Index Advisor pages.

We will provide the next update by 8pm Pacific / 4am UTC.
Posted Dec 19, 2023 - 01:39 UTC
Identified
We're currently experiencing a data availability issue related to index statistics, including index size and index activity metrics. We're working to restore the affected data from a backup, and expect to have this completed within a few hours. During this issue the unused index check (part of Index Advisor) will be unavailable and show outdated information.

Other statistics and advisor recommendations are not affected, and both Index Advisor's missing index check and VACUUM Advisor continue to function.

We will provide the next update by 6pm Pacific / 2am UTC.
Posted Dec 18, 2023 - 23:51 UTC
This incident affected: Dashboard, Statistics Data API, and Advisors Data Analysis.